Controlar IP en PL desde PS

Introduccion

En esta practica se agregara IP instanciada en el bloque PS y la misma se controlara por
software desde el PS.

Objetivos

e Agregar IP en el bloque PL de la FPGA.
e Configurar el GP Master port del bloque PS para conectarlo a la IP en el bloque PL
e Ejecutar una aplicacion de test para probar el funcionamiento de la IP agregada

Procedimiento

Crear el nuevo Proyecto

1. Abrir el proyecto anterior y guardarlo como Lab2PS para ello seleccionar el menu
File -> Project -> Save As.... Verificar que la opcion Create Project Subdirectory
este seleccionada. Presionar OK. Se creara el nuevo proyecto Lab2PS en su
correspondiente directorio.

2. Abrir el diseno de hardware Flow Navigator -> IP Integrator -> Open Block
Design.

Agregar tres instancias del bloque IP GP1O

1. Dar doble click en el bloque Zynq block para abrir la ventana de configuracion.

2. Seleccionar el menu PS-PL Configuration (ubicado a la izquierda de la ventana).

3. Expandir la opcion AXI Non Secure Enablement -> GP Master AXI Interfaces,
dar click en el recuadro M_AXI_GP0 interface para habilitar el puerto AXI GPO.

4. Expandir la opcion General -> Enable Clock Resets y seleccionar la opcion
FCLK_RESETO0_N.

5. Seleccionar el menu Clock Configuration (ubicado a la izquierda de la ventana).
Expandir la opcién PL Fabric Clocks y seleccionar la opcion FCLK_CLKO (con
requested clock frequency de 100.000000 MHz) y presionar OK.

6. En el bloque Zynq se agrego la interfaz M_AXI_GPO y las sefiales
M_AXI_GPO_ACLK, FCLK_CLKO0, and FCLK_RESET0_N
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Blogue Zyng con las interfaces AXI y CLK

8. Presionar el boton derecho del raton en el diagrama y seleccionar Add IP. Buscar el
bloque AXI GPIO en el catalogo.



9. Dar doble click en el bloque AXI GPIO para agregarlo al sistema. En el diagrama
aparecera el nuevo bloque. Ubicarlo en un lugar conveniente del diagrama (p.e;j.
debajo del bloque Zynq).

10. Presionar sobre el bloque AXI GPIO para seleccionarlo. En el panel Block
Properties cambiar el nombre de axi_gpio_0 a Switches
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11. Dar doble click en el bloque AXI GPIO para abrir la ventana de configuracion Re-
customize IP.

12. En el menu desplegable Board Interface correspondiente a GPIO, seleccionar sws
2bits (la placa Arty Z7-20 tiene dos interruptores).

13. Cambiar a la pestania IP configuration y verificar que GPIO Width esta configurado
en "2", que coincide con la cantidad de interruptores de la placa.

El periférico puede configurarse para dos canales, pero dado que se utilizara un solo
canal sin interrupciones, dejar sin chequear las opciones Enable Dual Channel y Enable
Interrupt.

14. Presionar OK para guardar la configuracion y cerrar la ventana.

15. En la parte superior de la ventana se activo la opcion Designer assistance available.
Presionar en Run Connection Automation y seleccionar /switches/S_AXI

16. Presionar OK para conectar la interfaz.
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Sistema con los interruptores conectados

En el diagrama se agregaron dos bloques adicionales: Processor System Reset y AXI
Interconnect. Se puede reordenar la ubicacion de los bloques para mayor claridad en las
conexiones.

18. Agregar otra instancia del periferico GPIO (Mediante Add IP). Cambiar el nombre a
buttons

19. Dar doble click en el nuevo bloque buttons, seleccionar en Board Interface la
opcion btns_4bits. Presionar OK.

El conexionado se puede hacer en forma automatica como en el bloque switches o en
forma manual. En este caso lo haremos en forma manual.

20. Dar doble click en el bloque AXI Interconnect (su nombre es ps7_0_axi_periph) y
cambiar el numero en Master Interfaces de 1 a 2 y presionar OK.
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AXI Interconnect (2.1) ‘

@ Documentation IP Location

Component Name  ps7_0_axi_periph

Top Level Settings - Slave Inferfaces | Master Interfaces

Number of Slave Interfaces 1 v
Mumber of Master Interfaces 2 v
Interconnect Optimization Strategy Custom v

AXl Interconnect includes IP Integrator automatic converter insertion and configuration.

‘When the endpoint IPs attached to the interfaces of the AXl Interconnect differ

in width, clack or protocol, a converter |P will automatically be added inside the interconnect
If a converter IP is inserted, IP integrator's parameter propagation automatically

configures the converter to match the design

To see which conversion IPs have been inserted, use the IP integrator

‘expand hierarchy’ buttons to explore inside the AXI Interconnect hierarhcy.

MNOTE Addressing information for AXI Interconnect is specified in the IP Integrator address editor.

Enable Advanced Configuration Options

Cancel

Agreagar otro master port al bloque AXI Interconnect

Presionar sobre la conexion S_AXI del bloque AXI GPIO buttons y arrastrar el lapiz
al bloque AXI Interconnect (no soltar el boton del raton).

Aparecera el mensaje 'Found 1 interface' y un tilde verde al lado de la conexion
MO1_AXI del bloque AXI Interconnect indicando que esa es una conexion valida.
Arrastrar el lapiz a esa conexion y soltar el boton del raton. Debera crearse una
conexion entre el bloque AXI Interconnect y el bloque GPIO buttons .

De la misma manera hacer las siguientes conexiones:

buttons /s_axi_aclk -> Zynq7 Processing System / FCLK _CLKO0

buttons /s_axi_aresetn -> Processor System Reset / peripheral aresetn

AXI Interconnect / MO1 _ACLK -> Zynq7 Processing System / FCLK CLKO0

AXI Interconnect / MO1_ARESETN -> Processor System Reset / peripheral _aresetn
The block diagram should look similar to this:
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Sistema despues de agregar el segundo bloque AXI GPIO

Agregar un tercer bloque AXI GPIO de la misma manera que el bloque buttons,
cambiar el nombre a Leds.

Dar doble click en el nuevo bloque leds. Seleccionar la pestafia IP configuration,
seleccionar All Outputs y en GPIO Width cambiar de 32 a 6. Presionar OK

Dar doble click en el bloque AXI Interconnect y agregar una interfaz master
adicional (cambiar el numero en Master Interfaces de 2 a 3). Presionar OK.

Hacer las siguientes conexiones:
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leds /S AXI -> AXI Interconnect / M02_AXI

leds /s _axi_aclk -> Zynq7 Processing System / FCLK CLK0

leds /s _axi_aresetn -> Processor System Reset / peripheral_aresetn

AXI Interconnect / M02 _ACLK -> Zynq7 Processing System / FCLK _CLK0

AXI Interconnect / M02_ARESETN -> Processor System Reset / peripheral aresetn

En el panel del diagrama, presionar en la pestafia Address Editor y expandir
processing_system7_0 -> Data -> Unmapped Slaves.

El bloque switches tiene asignado un rango de direcciones en forma automatica, pero
los bloques buttons y leds no, ya que se conectaron manualmente. Presionar sobre la
primer entrada debajo de Unmapped Slaves para seleccionarla; presionar el boton
derecho del raton y seleccionar la opcion Assign Address .
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v ¥ processing_system7_0
v [ Data (32 address bils - 0x40000000{ 1G
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Exclude Segment
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Exportio Spreadsheet

Periféricos mapeados a memoria

Conexion externa de los periféricos GPIO

Las instancias buttons, switches y leds se deben conectar a pines de I/O asociados a los
correspondientes elementos de la placa. Esto se puede hacer manualmente o mediante el
asistente Designer Assitance. La informacion para saber a que pines de 1/0 estan
conectados los elementos de la placa esta en el manual de la placa..
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En la vista del diagraa, la opcion Designer Assistance esta disponible, igualmente
vamos a conectar los puertos manualmente.

Presionar el boton derecho del raton sobre el puerto GPIO del bloque buttons y
seleccionar la opcion Make External para crear la conexion externa. Esto creara un
puerto externo denominado GPIO_0 conectado al bloque. Como el entorno de
desarrollo tiene identificada la placa utilizada, la asignacion de pines de 1/0 de la
FPGA se hace automaticamente.

. Cambiar el nombre GPIO_0 a buttons en el panel External Interface Properties

(pestana General).

. Para el bloque leds presionar el enlace Run Connection Automation.
. En la ventana seleccionar leds -> GPIP y en la parte de Options seleccionar custom.

Presionar OK

. Cambiar el nombre gpio_rtl a leds
. Cambiar el nombre sws_2bits a switches en el bloque switches
. Ejecutar la validacion de disefio (Tools -> Validate Design) y verificar que no hay

errores. El sistema deberia verse similar a la siguiente figura
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Sistema Completo
9. En el panel Flow Navigator presionar en Run Synthesis. (presionar el boton Save si
aparece una ventana emergente para guardar el proyecto) y cuando finaliza el proceso
en la ventana emergente cambiar a la opcion Open Synthesized Design y presionar
OK (no se puede elegir Run Implementation porque no estan todos los pines de I/O
asignados)
10. En el menu de atajos (arriba a la derecha) seleccionar I/O Planning
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Seleccionar la vista 10 planning

3. En la pestaiia I/O ports (parte inferior de la pantalla), expandir las tres entradas
GPIO

4. Al expandir switches_tri_i se observara que los puertos han sido asignados
automaticamente, con ubicaciones fisicas (M19 y M20) y I/O Std LVCMOS33

5. Al expandir buttons_tr_i se observara que los puertos han sido asignados
automaticamente, con ubicaciones fisicas (L19, .20, D20y D19) y I/O Std
LVCMOS33

6. Al expandir leds_tri_o se observa que no hay pines asignados. Asignar
leds tri_of5] -> Package Pin M15 -> 1/O Std LVCMOS33
leds tri_of4] -> Package Pin N15 -> I/O Std LVCMOS33
leds tri_o[3] -> Package Pin M14 -> I/O Std LVCMOS33
leds tri_o[2] -> Package Pin N16 -> /O Std LVCMOS33
leds tri_ofl1] -> Package Pin P14 -> 1/O Std LVCMOS33

leds tri_o[0] -> Package Pin R14 -> I/O Std LVCMOS33

Generar el archivo de configuracion Bitstream y exportar a SDK

1. En PROGRAM AND DEBUG seleccionar Generate Bitstream. presionar el boton
Save si aparece una ventana emergente para guardar el proyecto. Presionar OK si
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aparece una ventana emergente informando que el disefio esta desactualizado (Out of
Date Design)

. En la ventana Emergente Save Constraints colocar el nombre de archivo

Constraints. Presionar OK

. Aparecera una ventana emergente avisando que la sintesis esta desactualizada,

presionar el boton Yes

. Cuando aparezca la ventana emerente Bitstream Generation Complete presionar

Cancel

. Presionar el enlace reload en la pestafia de la parte superior de la pantalla
. Exportar el disefio de hardware mediante el menu File -> Export -> Export

Hardware. Verificar que este chequeado el recuadro Include Bitstream y presionar
OK. En este caso hay hadware instanciado en el bloque PL, por lo que se gener6 un
bitstream que debe ser incluido en la exportacion a SDK.

. En la ventana emergente presionar Yes para sobreescribir el archivo exportado (este

archivo habia sido previamiente creado en el Proyecto Labl).

. Iniciar la herramienta SDK presionando File > Launch SDK. Presionar OK.

Generar la aplicacion TestApp en SDK

1.

En la herramienta SDK, presionar el boton derecho del raton en el Proyecto
mem_test y seleccionar la opcion Close Project

. Hacer lo mismo para los proyectos mem_test_bsp y

system_wrapper_hw_platform_0

. En el menu de la parte superior seleccionar File > New > Board Support Package

. Presionar el boton Finish con las opciones por defecto (Board Suppor Package OS

standalone OS, Hardware Platform system_wrapper_hw_platform_1 y nombre
por defecto del Proyecto standalone_bsp_0

. Presionar OK en la ventana emergente con las opciones por defecto.
. En el menu de la parte superior seleccionar File > New > Application Project

. El nombre del proyecto es TestApp, en la seccion Board Support Package (al

final), seleccionar Use existing (standalone _bsp () y presionar Next.
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I

Create a managed make application project. i 7

Project name: | TestAp |

Use default location
tion: | Chkupiemnbedded\2018.1 zyng labsilab 2ilab 2isdk\Testhp

default

05 Platform: | standalone e

Target Hardware
Hardware Platform: | system_wrapper_hw_platform_0 | | New..,
Processor: ps7_cortexad 0 St
Target Software
Language: @®C O C+
32-bit

: M/A

Board Support Package: () Create Mew TestAp_bsp

(®) Use existing standalone bsp 0 i

(?) = Back Mext = Cancel

Configuracion del Proyecto Application Project
8. En la ventana emergente seleccionar Empty Application y presionar Finish
Esto creara un nuevo Proyecto TestApp usando el Proyecto BSP creado.

9. El gestor de librerias crea el archivo xparameters.h in el directorio
lab22.sdk_bsp 07 cortexa9 0

. Este archivo contiene las definiciones de direcciones de los periféricos.

10. Expandir el proyecto TestApp. Presionar el boton derecho del rato en la carpeta src 'y
seleccionar Import

11. En la ventana emergente expandir la categoria General y dar doble click en la opcion
File System.

12. En la ventana emergente, presionar el boton Browse y navegar hasta la carpeta donde
se encuentra el archivo lab2IQ.c. Presionar el boton Aceptar

13. Seleccionar el archivo lab2I0.c¢ y presionar Finish.

Prueba de funcionamiento en el Hardware

1. En el menu de la parte superior seleccionar Xilinx -> Program FPGA

2. Presionar el boton Program para configurar la FPGA. Cuando el proceso finalice, el
led Done de la placa se iluminara en color verde. Seleccionar nuevamente la pestafia
SDK Terminal

3. Seleccionar la pestaiia SDK Terminal en la parte inferior de la pantalla
4. Presionar el boton + y verificar los parametros de puerto COM y velocidad de

transmision si es necesario (normalmente estan los parametros del Labl). Presionar
OK. En la pantalla del terminal aparecera el texto Connected to COMxx at 115200



5. En el panel Project Explorer select el proyecto TestApp in Project Explorer.
Presionar el boton derecho del raton y elegir del menu desplegable la opcion Run As
-> Launch on Hardware (System Debugger) para ejecutar la aplicacion.

6. Seleccionar nuevamente la pestaiia SDK Terminal. Se debe ver un texto similar al
siguiente (dependiendo de los botones e interruptores activos)

IDIP Switch Status 6
Push Buttons Status 8
DIP Switch Status 6
Push Buttons Status 8
DIP Switch Status 6
Push Buttons Status 8
DIP Switch Status 6
Push Buttons Status 8
DIP Switch Status 6
Push Buttons Status 8

Salida de SDK Terminal

Al presionar un pulsador o interruptor, se encendera el led correspondiente y se
actualizara el valor en el SDK Terminal. Tener en cuenta que puede haber un
pequefio retraso porque el programa se ejecuta una vez por segundo.

7. Cerrar la herramienta SDK y Vivado mediante la opcion de menu File -> Exit en
ambas herramientas

8. Conclusion

En la practica se agregaron periféricos GPIO obtenidos del catalogo de IP. Estos se
conectaron al PS a través de la interfaz Master GP(. Los periféricos se configuraron en
tamarfio de datos y se conectaron a pines externos de la FPGA. Se creo una aplicacion de
prueba y se verifico la funcionalidad en el hardware.



